Got bugs? Leave them here

I’m having a consistent and annoying issue with the RescueTime Assistant app on Windows 11 (10.0.22000 Build 22000). After every focus session, and at some other random times, the Assistant app in the system tray disappears (using RescueTime, but this also occurred in The RescueTime process is still running as I can see it in Task Manager. If I shut it down there and restart, the Assistant app reappears, but then disappears again after first access. I’ve tried reinstalling with no luck.

Hi. After the new Focus session update, my app becomes stuck every time I finished a focus session. The focus session summary page won’t load after 20 minutes. The app is also showing a much higher CPU usage (around 30%) when this happens. Is there a way to solve this?

Additionally, is there a way to remember or skip the focus session setup, so that I don’t have to click on the setup options every time to start a session? Thanks.

Hi @marco_chen! We’re currently working on a fix for this bug with the Focus Session summary report on the Assistant. Thanks for your patience!

You can skip the Focus Session prep by clicking this button.

1 Like

Hi @DrFranco, sorry for the annoyance. Can you please email us directly at so we can look into your account. Thanks!

Hi @marco_chen, the Focus Session summary on the Assistant should be fixed now. Can you run a test and let me know?

Hi. I don’t think the session loads; maybe my rescue time did not get an update? I have tried restarting the app and checking for updates. It is still now. A high CPU usage still occurs when the session result tries to load, so I don’t know if this is due to some app settings.

Hi @marco_chen! Sorry it’s not working as it should. Could you email our support team directly so we can look into your account? I just discussed the CPU usage issue w/our developers and they’re going to investigate.

A few things I’ve noticed since the new focustime functionality was added:

  • Pausing tracking seems to be buggy after the first time. Once a pause completes, starting another pause requires some odd UI interaction: press pause button → pause button immediately de-selects itself, but pause menu still appears → select pause duration → ambiguous as to whether pause started → press pause again, select duration → UI behaves as expected. Manually ending a pause session causes the next pause session to work as expected. The client sometimes bugs even further and refuses to properly visually enter a pause session, requiring a client restart.
  • When a focus session is enabled, the client consumes a significant amount of CPU resources. This is presumably because the little GUI for pause session is constantly updating, even if the client is minimized.
  • After a focus session completes, my client almost always shows 0 or only a couple minutes spent in the session. After closing the focus summary UI, the client syncs and total focus time updates to reflect the actual time spent focusing.

I’ve noticed that music from rescue time start to play sometime, when you open widget even when sound is off.

1 Like

Another one since the last update on Windows: when adding offline time the interface no longer closes itself. After entering offline time you have to manually close the interface

1 Like

Hi @peter. Can you elaborate? Music from your Spotify that’s connected to RescueTime?

Thanks so much for this feedback @evan!

  • We’re looking into the pause bug

  • We have received reports about this from a few users as well and are investigating. We’re always working to optimize our system.

  • Regarding your Focus Session summary report, please ensure you have the latest version of RescueTime installed. If this continues to be an issue please reach out to our support team - - for additional support.

Adding my bug report to this. I don’t use RescueTime’s Focus Session music but usually have music playing from Spotify. I choose “no music” when starting the session. Now if I use the “stop/start music” button on my AirPods Max, it starts to play some random ambient from RescueTime on top of the Spotify audio. Somehow RescueTime seems to hijack the audio play/stop command and after that it’s very easy to end up in a situation where you can’t turn the ambient off, as you only have on-screen controls to start and stop the music playing from Spotify but the AirPod controls also revert to controlling Spotify again etc. ResceuTime only shows the Spotify music playing but no controls for the ambient it’s forcing on me. I basically have to remember to not try to use the AirPod controls at all when I’m running a focus session.


  • Mac user, newest OS version

the sync between starting a focus session on my mac and do not disturb turning on automatically on my Oneplus doesn’t work anymore.

Also I wanted to ask: I use dual monitors, does RT log in the time related to the mouse pointer or does it sum the time from both monitors ?


While I’m not the original poster, I have submitted this same issue both in the chat and via an email together with a screen recording.

Hi @jaakko_koivula! Yes, I have heard and seen some hijacking take place. Our developers are investigating this issue. In the meantime, If you’d like to use your AirPod controls, then you can uncheck “Sounds on” in the Assistant settings. We share more details here on how to disable the sounds.

1 Like

Hi @VFP! Could you email us at with your troubleshooting diagnostics? Let me know if you need help finding that.

As for dual monitors, RescueTime records and reports time spent on whatever app/website that’s in the foreground that you are active in with your keyboard or pointer device.

1 Like

Thanks @smilyte! I found your email. Just to update you on this CPU issue, our developers may have found a solution to optimize this better, and they will be prioritizing this soon.

Hi @jaakko_koivula, our developers may have fixed the hijacking issue with your AirPods Max. Let us know if you’re still having problems?

I have a few bugs to report:

  1. On Mac, the “Tour the Assistant” and “Connect to your Calendar” checkmarks are persistent. This is okay to show after first setting it up, but otherwise it takes up 1/2 of the application space with no value add. It should be removed.
  2. On Mac, the “On”, “+” and Focus session buttons sometimes disappear at the bottom of the app and I need to restart the app.
  3. “Focus Session” count on the Goals tab of the website, only show manually started focus sessions and do not show automatically started focus sessions.
  4. There should be a way to select a particular day and look at data. I often want to do a week in review. I cannot look at anything but today, yesterday, or an aggregate of a week / 30 days. What if I want to look at data for a single day?
  5. Another issue is the Android app, the scrolling is broken. You need to use two fingers to scroll. This should be an easy fix, and seems a little bit sloppy.
  6. There is no way, like in RescueTime Classic, to block websites or apps on android/iOS, making the focus sessions less useful.
  7. There should be a way to set personal goals. I want to track time spent doing hobbies/exercise, beyond work, and simply having these count as “distractions” is counterintuitive. They are not distractions. There should be settings to place these things in other categories that are customized.